UVI Workstation


#1

hi,

it’s release time for JUCE based apps these days, check this out:

UVI Workstation http://www.uvisoundsource.com/

and thanks for the support on this forum.


#2

Another great-looking app! I’m downloading the demo now…


#3

Wow! looks so nice!
I’ll try it soon!

  • Masa

#4

Looks really nice! (And now my favourite question again) How did you manage to get the fonts so smooth? Did you use JUCE’s font rendering or another one? Them fonts look really great! :wink:


#5

Unfortunately my XP crashes (reboots) instantly as soon as I start the app, so I can’t comment on the UI. I guess something in the audio departement cannot fail or fall back gracefully.


#6

One of my favourite topic too :slight_smile:

Yes, it’s juce standard Font rendering with carefully chosen fonts. Serialized in juce format.
But if we could load them directly from truetype I wouldn’t complain :wink:

For this product have we enough room for vector fonts appart from the RSS feed which uses a pixel accurate font with a hand tuned size (10.01 instead of 8px) and Justification::topLeft in order to for the first glyph to start on integer pixel coordinates.

again I wouldn’t complain if I could use Justification::centred with a roundToIntegerCoordinates flag…


#7

Did you try it after yesterday night GMT+1?


#8

Well, I tried it yesterday afternoon CET. if there’s a new version, I’ll give it a shot.


#9

We won’t pollute too much the Juce forum about this.

There was an issue with the VST version which make it crash directly.
This is now fixed.

If you tried the StandAlone version then we never heard of such issue.

Moreover, we currently use Juce Audio input/output in the SA version.
So if it crashes right away in something related to the audio then there is wrong, and you’ll maybe have the same issue with the juce demo.


#10

fyi, setup freezes here on WinXP, while “Installing Pace Support”…


#11

On windows, the UVI Workstation crashes in juce host when in debug mode. Of course so do lots of plugins in the Juce audio but this one is significant. It was written in juce, correct? I check it out in the Juce Host demo and it hangs at the LoadLibrary call.

Any solutions?


#12

I’ve seen iLock protected plugins not able to be instantiated or scanned while XCode is running.

Rail


#13

Yep, it's iLok protected, so usually it doesn't like to run under a debugger.

 


#14

That is what I suspected. I was hoping there is a work around for developers.

Thanks