VS2013 and Unicode project setting


#1

I've just switched to VS2013, and converted to unicode, but each time I save the project after changes, the 'Character set' parameter in the project gets reset and requires manually setting to unicode.  Is there a way to get the Introjucer to set this to Unicode?


#2

Im on my phone right now, but iirc, you can change that setting in the Introjucer project of yours for VS2010 and up.


#3

Adding _UNICODE and UNICODE to the 'Extra preprocessor definitions' section of the config for VS2013 has the desired effect as far as the compiler is concerned, but the project properties General/Character Set remains stubbornly blank - which was confusing me


#4

I think you misunderstood what I meant: every Visual Studio exporter, from 2010 and up, has the Character Set setting. This is per exporter configuration (e.g.: Release has its own, Debug has its own).

This is not a per VS solution flag, but per project's configuration.