VST only visible on my machine


#1

Hi, I've created a VST using Introjucer with V3 and it loads and runs fine on my machine. Have sent a copy to a friend for testing and it's not showing up on their machine.

Anything I shold be aware of?

thanks


#2

Hi, anyone got any suggestions of things to look into?


#3

Probably a missing Microsoft Redistributable? I'm assuming this is a Windows machine?


#4

Hi, thx for the suggestion, will bear that in mind for windows, but currently seeing the issue on OS X 


#5

When you say not showing up, what do you mean?

For example, is there an empty window? No window at all? Are they using the same host? Are you both on the same version of OSX?

More information is needed to help :)


#6

Hi, sorry, yes I mean not showing up as it not listed by hosts, e.g. Live/Logic as availalble VSTs. We're both running 10.10.5.


#7

Got round to trying on Windows machine and it's fine - just OSX that it won't show up...


#8

It sounds to me like your friend might not need some help in getting his DAW to see the plugin. I'm not trying to be a smart arse, but if it works on all the PCs you've tried it on, and you both have the same OS? Could it be that he just isn't loading it correctly? I can't think of any other problem. Unless of course you are linking to external libraries that you are failing to ship with your plugin?


#9

Hi, tried it on 3 other machines now. No external libraries involved and no linking apart from to standard frameworks.

They've sent me grabs with it installed in the same location as other VSTs that are showing up in the DAW. We're all running on 10.10.

Most strange.