Weird behavior of Convolution Engine or normal?


#1

Hi, i’m playing more and more with the convolution, i found out this strange behavior in Studio One 3:

-If i load an impulse having Asio set on low samples (between 72 - 256) around that range, 60% of the times the left channel or the Right (sometime both) click and disappear, first thing that i thought is that was normal setting so low latency, but then i realized that never happens if i set it even lower, setting 64 samples on the Asio it never fails.

-it fails only in the release version, i tried to debug to see if i could figure out where is failing but in debug version that is slower and very cpu consuming never fails, i can’t figure out if it’s something that studio one doesn’t like in the juce convolution engine or what :frowning:

In the test i tried all the load funcions, from File, from Binary and from Buffer and the result is the same in all of them, lowest latency (64 samples) always work perfectly, then setting it higher than that it very often fails untill around 256 or little higher than that, after that value it’s stable again, now i probably try the plugin host in release mode to see if has the same behavior, i’ll update