WM_CLASS missing GNOME 3


#1

During our app internal testing we headed some problems with GNOME desktop env.

First one of our tester either keyboard or mouse didn’t worked.

And also task bar icon do not shown as it’s shown when other desktops are in use, could be missing WM_CLASS.

What it’s and how this can be fixed ?


#2

Could you please provide an example where the keyboard and mouse are not working, or give us some steps to reproduce the issue?


#3

Did anybody ever find a way to solve the WM_CLASS issue? My app gets no icon on Ubuntu 18.04


#4

Hmmm that’s strange. Just tested the Projucer on Ubuntu 18.04 LTS and the icon seems fine.


#5

Is there anything I need to do to get my window Icon to show up? I added an icon in the Linux exporter. I also tried getting the peer after I call addToDesktop() and setting an icon. Neither seem to have an effect.

I noticed which Projucer has an icon, it doesn’t have an application name.

Sometimes the following will get the icon to show up:
xprop -name “AppName” -f WMCLASS 8s -set WM_CLASS “AppName”