Xcode can't find some methods


#1

Hi everyone!
I was doing other tutorials with the only problem of not being able to access the libraries without copying the files to the project directory. That was solved by copying and I was able to move forward with several of the tutorials.
Now I think I have a problem related to that but that I am not able to solve:
There are no methods that should be included in the Button and Slider classes.
See the image, does anyone have any ideas?

Thanks!

PD: It is rare that error is marked in lines where it does not correspond.


#2

First, openButton.onClick() = ... would rather call the lambda than setting it.
But the error message looks more like you copied old modules, when that lambda was not yet available.

You shouldn’t have to copy the modules. Make sure, in Projucer in the section “modules” to set the right path to the location where your JUCE/modules are located.
Once you set this, save the project and rebuild in your IDE.

Also ideally use git to always checkout the latest version, and check to be on the right branch, master for released software or develop for the latest tip.

Hope that helps


#3

Thank you.
I think there is some strange problem that I can not find.
I already had problems before with the path of the libraries that I solved by copying the directories through Projucer.
But now, I updated the modules with the last master branch and I find new problems like this one indicated in the image.
In another of the tutorials, now Xcode does not find the libraries or even copying them, despite being able to view them in the folder tree.


#4

N.B. if that’s XCode 10, I suggest downgrading to 9 for now, there is a lot broken at the moment, especially with relative paths…

See here, I don’t think it’s stable yet: