XmlDocument and debugger


#1

Marching through large XML files (1000 tags, etc.) with debugger on, is almost impossible. It takes several seconds on large files. Is there some trick to disable the Juce string checking that is going on or maybe something I have missed?


#2

Not sure what you mean by “marching through”…?


#3

I have xml files containing data on all the major sample libraries (over 50). Some libraries contain thousands of samples. The xml file contains data for each sample, like key switch info, controller info, range, etc. When a user chooses a sample/instrument from the library, my program scans through the matching xml file looking for the data for that particular sample. This takes seconds when the debugger is enabled and I think it’s because each string is checked to see if it’s valid, contains non-unicode characters, etc. I could be wrong but after looking at the juce code, the only solution I have found is to create another macro DEBUG_STRS and wrap that around the code that checks strings, instead of DEBUG. It’s works fine in release mode. So is there a quick trick to disable this?

As I stated before this is a very large program and is not a little plugin. It’s time to think big!

Any ideas?


#4

Ok, I see. TBH the easiest thing might just be to comment-out the assertion if it’s getting in the way.


#5

OK, I’ll look into it. I just downloaded rapidXML and may have to use it. Speed is important.

Merry Christmas!