AAX SDK version...?


#1

Hi,
What version of the AAX SDK is Juce targeting? Changes made about a month ago: “AAX transport position when stopped.” seem to break compatibility with the SDK I have (1.5.0). I’m pretty sure my test builds worked before that, and now there are references to stuff that doesn’t exist in my SDK (1.5.0)


#2

AFAIK 2.0.1


#3

Thanks. When I installed the 1.5.0 version it was the latest and 2.0 was in beta.


#4

Also make sure the PT build you’re testing in is recent or you will get asserts.

Rail


#5

[quote=“Rail Jon Rogut”]Also make sure the PT build you’re testing in is recent or you will get asserts.

Rail[/quote]
That’s interesting; what kind of asserts? Would the earliest PT version with AAX support not work well with plug-ins build with AAX SDK 2?


#6

[quote=“Mike”][quote=“Rail Jon Rogut”]Also make sure the PT build you’re testing in is recent or you will get asserts.

Rail[/quote]
That’s interesting; what kind of asserts? Would the earliest PT version with AAX support not work well with plug-ins build with AAX SDK 2?[/quote]
You absolutely need to go to the 2.01 SDK. Builds with earlier versions of Juce had a number of other problems, the most significant being an issue with plugin ID. This broke the ability to smoothly go from RTAS to AAX. In addition, you’ll find that earlier builds might work well on 32-bit AAX, but would then fail at 64-bit.

The transition to the 2.01 AAX SDK is pretty painless, so there are lots of reasons to do it and no real reason not to.


#7

[quote=“Mike”][quote=“Rail Jon Rogut”]Also make sure the PT build you’re testing in is recent or you will get asserts.

Rail[/quote]
That’s interesting; what kind of asserts? Would the earliest PT version with AAX support not work well with plug-ins build with AAX SDK 2?[/quote]

See http://www.rawmaterialsoftware.com/viewtopic.php?f=8&t=11030

If you tried to use a 2.x function in an older build it would assert on the new function

Rail