After update to JUCE v6.0.1 there is some mess with modules

I work with one project (audio plugin) simultaneously on OSX xCode and Windows 10 Visual Studio.
And for all modules I set:

  • Use global path for this module - OFF
  • Copy the module into the project folder - ON;
  • Make module files browsable in project - ON

To be sure on both machines I always work on the same modules.

And it was never problem until I updated JUCE to v6.0.1 (of course on both machines)
But now I have following problems:
On OSX xCode
Everytime I run the project from Projucer by clicking xCode icon button, and then I want to close Projucer it asks me if I want to save changes but I made no changes. Even if I click “save” the next time I have the same question.

It’s not big deal and I can live with that. But on Windows I have much bigger problems.

On Windows 10 Visual Studio 2017
Everytime I run the project from Projucer by clicking VS icon button I have the same issue like in OSX - always asks me to save changes. But the bigger problem is that it always generates thousands changes in modules files, and my git client Sourcetree sees thousands changes to commit (please find enclosed screenshot).
And the project compiles without problem, so I commited those thousands changes, but then I get errors on xCode, and can’t compile at all.

But when I discard all thousands changes it compiles without problems on both VS and xCode.
So it looks like those changes are not necessary. But everytime I launch the project in VS I need to discard thousands changes which is annoying.

Have anyone of you similar problems? And how to solve it?

For any help great thanks in advance.

Best regards

Are you by any chance using LF as the line endings in Xcode, instead of CR/LF? And what is the setting in Projucer? If every file is always marked as changed, that sure sounds like the line endings are changing.

But what are the errors in Xcode after doing that? Xcode’s compiler shouldn’t care about what the line endings are in the source code, so that’s a little odd.

Oh, and I get that save prompt a lot, too. Most of the time I just ignore it. I found that if I select a Group in the File Explorer (not a file, but the Group containing it), then Save, and then click Save and Export in IDE, I can close the Projucer project without that prompt. (Provided I do so immediately, before making changes in the IDE.) Kind of annoying, huh?

no unfortunately it’s not problem with text encoding or mess with LF vs CR/LF.

There are some problems with libraries at all. Looks like they are different for OSX and different for Windows. I know it sounds stupid, but it seems to be true. I still hope it’s some problems with my projucer project settings. But please notice that before Juce v6.0.1 I had never such problems.

According to your question, the error on OSX is missed file juce_CompilerWarnings.h
Please find enclosed screenshot.