Android Target SDK is now unsupported by Play Store

Just tried to upload a build I’ve made from latest develop (0bac0e).
Target is still 29 which is now getting the following on Play Store:

Your app currently targets API level 29 and must target at least API level 30 to ensure it is built on the latest APIs optimized for security and performance. Change your app’s target API level to at least 30. Learn More

I was still able to build with SDK 30 level which at least I guess should become now the default value on Projucer.

Thank you for reporting. We’ll push a fix shortly.

1 Like

Unfortunately this has serious impact on file access.
For now I can’t see a way to launch our app, as it doesn’t meet the rules
It’s also discussed here.
I hope the JUCE team have an eye on this?