Apple ventura M2 build settings plugin error unsupported architecture ARM64Bit

I need some help compiling JUCE for a new M2 macbook air.
Some screenshots of settings that look like they might be relevant and the error.
Very little documentation about what these settings do or how they should be set.

Mac OS 13.2.1
I see this error in cubase
“Unsupported architecture ARM64Bit” error in Cubase 12.

The standalone version of the plugin seems to be built.
Just boilerplate JUCE code in the plugin
Juce version 7.0.5

mac os Model Name: MacBook Air
Model Identifier: Mac14,2
Model Number: Z15T0005NLL/A
Chip: Apple M2
Total Number of Cores: 8 (4 performance and 4 efficiency)
Memory: 24 GB
System Firmware Version: 8419.80.7
OS Loader Version: 8419.80.7
Serial Number (system): XCK2P29KG5
Hardware UUID: 493211E1-4015-535F-B450-63371CC8416B
Provisioning UDID: 00008112-0008318026F9401E
Activation Lock Status: Enabled

I would try to set in Xcode under destinations “Any Mac” instead of My Mac.
Chances are (guessing), Cubase 12 runs under Rosetta, in which case it would need an intel plugin.
A quick google told me Cubase 12 should be able to run M2 natively, but who knows…

At least it improves your chances.

Disable the 32 bit options in Valid Architectures… only select x86_64 and arm64

If you Get Info on Cubase 12 you should have the option to run under Rosetta or Native arm64.


I tried checking the “open using rosetta” box in cubase and only selected 2 architectures. Same issue

Screenshot 2023-04-09 at 8.28.21 PM

Ok this WORKED. Checking only arm64 in the projucer.
Open using Rosetta unchecked in cubase 12.
In Xcode In “product”-> destination checking "any mac(silicon)
thanks for your replies

That means in Xcode you didn’t have it targeting all platforms when you were building the project.

It should be Any Mac (Apple Silicon, Intel)


Thanks !

If I remember correctly with arm64 Apple requires code signing for loading dlls.


try to run your build to Rosetta:

Screenshot 2023-10-27 at 17.07.52