Audio input not working in demo projects

Hi there. Totally new to JUCE.
I’ve tried a few examples in Projucer, which generate audio, and they work fine.
I want to dig into audio processing, so I also tried the AudioRecordingDemo, but I cannot get audio input working.

I’m on macOS, so I’ve enabled Microphone Access (Exporters -> Xcode (MacOSX) -> Microphone Access), and also tried saving the demo as a new project, but to no avail. No sound is being recorded, when I start the project and click the record button. The resulting .wav files in my Documents folder are also silent.

I assume Projucer will use the default system input, which I’ve made sure is set to the Internal Microphone. What to try next?


Thanks for the link. I also get no dialog asking me if Mic access should be allowed. It seems though, there were no resolution to the problem in that topic, if I read it correctly?

Edit: ah, now I’m getting somewhere. I just launched the project using the “Play” button. I need to open it in Xcode and compile and run it from there. That way I get the dialog about Mic access, and everything works.

For me as a newcomer, understanding the difference between Projucer and Exporters is a bit tricky. Maybe it should be documented in the specific examples themselves, that they need to be run via eg. Xcode.

Or maybe the project can actually run inside Projucer on macOS, if the Projucer itself just gets the correct entitlements. That would be simpler for newcomers :slight_smile:

Thanks for the pointers @Rail_Jon_Rogut

This was done in, which is now part of JUCE 5.4.5.

Thanks for the reply. I tried updating to 5.4.5, and I can confirm that the Info.plist contains the relevant <key>, but I receive no confirmation dialog about microphone access.

Anyway, not a deal breaker for me, since I can launch via Xcode without any problems.

I have, however, tried launching the demo project from CLion, and in this case the confirmation dialog is never shown, and there is no audio input. I wonder if anybody has had luck with that usage scenario?

Edit: answering my own question. When launching the application from within CLion, no dialog is shown. But by revealing the build folder in Finder, and then launching the app, I made the dialog show, and audio input worked perfectly.

It might be possible to somehow attach the debugger when launching the app this way, but I haven’t experimented with it more.