Processing Audio Input - enable microphone reminder?


Hey there

@t0m this might be one for you. :slight_smile:
The tutorials in general have a really nice tendency to remind the newcomer of things to bear in mind. Items that I’m certain are blatantly obvious to JUCE users with moderate experience (ie more than mine).

As a result it took me an embarrassing hour or so to realise that with the “Processing audio input” tutorial I needed to enable microphone input in Projucer. I understand why it’s off as a default but I’m certain a few newcomers would benefit from the line “As you are using audio input functionality, remember to enable this in Projucer”.

I spent way too long googling and trying to figure out if Mojave security was the culprit interfering with my device permissions.





Thanks for the feedback - we’ll get that updated.