We have these 3 new methods available in AudioProcessor class. Why not to use these methods in the wrappers (VstWrapper, AudioUnitWrapper, etc.) instead of constants defined in juce_IncludeCharacteristics.h (JucePlugin_WantsMidiInput, JucePlugin_ProducesMidiOutput, JucePlugin_Name).
Now the same things need to be described twice. I know that these defined values can be simply returned in mentioned methods but maybe it would be more clear if the plugin behaviour and characteristics were described only by AudioProcessor’s virtual methods.