Bug, mouseMove() not called, in VST, Retina, 64Bit


#1

The mouseMove Callback is not called when the mouse moves over a component,

even when the window is in front, and was previously  clicked with the mouse.

Hopefully this will be fixed as fast as possible, its major issue here :-/

Appears so far with VST (in Tracktion, Ableton Live 9) , 64bit and Retina display on Max OS X 10.9.5 with latest tip from github

 

 

 


#2

I can't reproduce. with reaper, 64bit, retina, and 10.8 it's working fine.


#3

yes the problem is may specific to the host and VST. Did you try Ableton live and tracktion (its build with juce, i used version 5.3.6 /64bit)

.  Its seems its working in Cubase too.


#4

I tried the vst in Live 9 and its working. Are you testing with the JuceDemoPlugin?


#5

Thanks for your efforts, i'm trying now to recreate the issue in the DEMO-Plugin. 

My investigation so far, with my own plugin, that even in the JuceNSViewClass the mouseMoved() Callback isn't called, while others like asyncMouseDown() are called. Has anybody an idea (especially Jules) , under which circumstances mouseMoved isn't called?

My only idea is that some kind of message queue is full, so that they don't reach my GUI, but thats pure speculation .....

 

 

 


#6

Have you got non-standard stuff going on in your program? OSX doesn't actually send mouse-moves to windows unless they have focus, so for plugins I had to add special workarounds that simulate them. That should work unless you've hacked something and prevented it happening.


#7

>>OSX doesn't actually send mouse-moves to windows unless they have focus

I know, but the windows HAVE focus! And it WORKS in AU and in VST with Cubase! But not in Tracktion and Ableton with VST.

But when, i just found out, when i check "Plugin editor requires keyboard focus", it works like it should!

So this option should be always on, if not, plugins in certain hosts didn't receive mouseMove when the HAVE focus.

 

 

 

 

 


#8

well, I got JucePlugin_EditorRequiresKeyboardFocus defined to 0 with the 2 plugs I tried. weird


#9

What do you mean with weird?, turning on "requires Keyboard focus" solved the issue here...

Which host did you test?


#10

I mean I'm not sure why there's an issue for you : I don't have any issue, even with JucePlugin_EditorRequiresKeyboardFocus defined to 0. 

Which host did you test?

reaper and live 9.

 


#11

I don't know, but it was definitely an issue here ;) 

I used Ableton Live 9.1.7, VST, 64bit, Retina, OSX 10.9.5

One thing, there might be some moveMove-Callbacks coming through, but these are triggered because of other mouse-events like click...

But the original continuous moseMove, which is called when mouse is moving over the component not. As like the window stays unfocused. 


#12

Have exactly the same issue with the VST OSX plugin in Live x64. No MouseMove or MouseEnter events. Setting JucePlugin_EditorRequiresKeyboardFocus to 1 fixes the issue, but i already fear the ableton live key stealing bugs if i enable this. 


#13

I have issue again, after i updated to 10.10 and to the latest tip a few days ago. 

"#define JucePlugin_EditorRequiresKeyboardFocus  1" does not fix the issue anymore. 

It happens in ableton live 9 64 bit with the vst and without a retina display.

Edit: i was able to reproduce it with the JUCE demo plugin. You can see it on the keyboard component.

Edit 2: after some more research i can see that the actual plugin UI never gets the focus. Input fields and combo boxes work. 

Can anyone reproduce this too?


#14

VST works here, but it seems now i have to click on the AU to get it work :-/ But AU also shows a "clock" as mouse symbol with first entry

Ableton 9.1.8 / 64bit / mac os 10.10.

ahhh, this is driving me mad!
 


#15

I updated ableton and it works now. Thanks for the hint :) Also have the Clock mouse pointer issue with the AU.