Building with Azure Pipelines - XServer Issues


#1

I’m experimenting with Azure Pipeline integration for a few reasons:

  • Cloud hosted Mac, Windows & Linux
  • Self-hosted runners (for iLok signing)
  • Nice GitHub integration
  • and a few other reasons

but I’m getting stuck on the XServer issue discussed here:

The PJ build but then I get this error in the log:
Failed to connect to the X Server.

I tried the xvfb trick above but get this error:
sh: 0: Can't open /etc/init.d/xvfb

Has anyone had any experience of this either with how to bypass this on Ubuntu (the hosted agent) or how to configure Azure Pipelines to deal with it?

Any pointers much appreciated.


#2

Very cool that your taking a look at Azure, unfortunately I don’t have any answers I’ve been too busy to really dive into Azure with that much detail just yet :frowning: (definitely on my todo list!)

Have you tried starting xvfb? maybe Travis has it running already? I can’t test any of this right now but I found some information here (http://elementalselenium.com/tips/38-headless) and here (http://manpages.ubuntu.com/manpages/cosmic/en/man1/xvfb-run.1.html)


#3

You legend, starting Xvfb manually did the trick:

      Xvfb :99 &
      export DISPLAY=:99
      sleep 3 # give xvfb some time to start

All builds working now!

Now on to deployment…


#4

This is something that I was also planning to investigate, would you be able to report back on the gotchas and/or make a tutorial?

One of the things I came across in my research was that you can use Chocolatey to install InnoSetup on the Windows VM if that’s your install builder for that platform.


#5

Awesome glad I could help! out of interest how are you finding the Azure service? it looks very promising to me - the only thing I want to dive into is if it’s possible to get Azure to launch up a VM for the local stuff but if all you use the local stuff for is PACE signing there shouldn’t be much need for that anyway!


#6

Ah, thanks for that info. We do use InnoSetup for installers. I hadn’t looked that far ahead yet.
I’m currently getting pluginval building and released on Azure Pipelines to test things out then will move on to our private projects which have installers.

Finally I’ll be looking in to plugins and for that need AAX signing so will probably have to run local agents to run the builds.

I’ve not looked in to the VM launching capabilities yet I’m afraid. Not see anything related to that either.

It’s good. A bit of a learning curve as it’s similar but very different to Travis. Mostly just lots of web searches and fixing problems one by one…