Cmake linking errors when using clion

Been trying to create a plugin using juce, I keep getting the below error.
I have tried deleting the CMake build folder,
Switched to Ninja from codeblocks “-G Ninja” and still the same link error.

However, using projucer to generate a visual studio 2019 project and using the same exact codebase runs just fine.

Using msvc

VBandEq_SharedCode.lib(PluginProcessor.cpp.obj) : error LNK2019: unresolved external symbol "public: __thiscall juce::dsp::IIR::Coefficients<float>::Coefficients<float>(float,float,float,float)" (??0?$Coefficients ... ) referenced in function "public: __thiscall juce::dsp::IIR::Filter<float>::Filter<float>(void)" (??0?$Filter..)

Plugins\juceq\Juceq_artefacts\Debug\Standalone\VBandEq.exe : fatal error LNK1120: 2 unresolved externals```

NB: replace % with at symbol

You probably need to add juce::juce_dsp to your target_link_libraries.

Am new to all this how do I do that exactly?

Edit: found this Help needed using CMake and importing juce_dsp - #3 by ZiggyBcn answer you posted,

Thanks this worked.