Code signing in Xcode 14.2

Hi my Xcode signing has stopped working in 14.2
To explain better than words here’s a few screen shots of what I’ve got so far.
Here’s my projucer settings.

This is my Xcode settings after running the Projucer…

Here’s my keychain information. It’s interesting that the private key now has the words ‘Mac Developer ID Application’ text in it rather than just the D Hoskins:

When I drag the created plug-in into ArchiChect, it says this:
signature error spctl error 3…

This all worked before, can any spot a problem with the above?
I can’t notarize, because of this.
Dave H.

I’m not sure, but according to this post, spctl error 3 indicates that the bundle hasn’t been notarized.

The signature info below says that the bundle has been adhoc-signed, which is not sufficient for notarization.

Have you specified a Development Team ID in the Xcode exporter settings in the Projucer?

Which copy of the plugin are you checking? The one in your ~/Library/Audio/Plug-Ins/Components, or the one in your build folder?

Thanks for looking at it. I drag it from ~/Library/Audio/Plug-Ins/Components
Note that Archichect also has no tick next to ‘valid signatures’

I can’t notarize the plug-in though, as notarytool just says ‘Invalid’ which doesn’t help at all.

I’ve just tried Xcode 14.1 as I know it worked before, but not any more.
So now I’m stuck, and running out of random things to try! :roll_eyes:

I’m a bit suspicious of the key in the keychain, as it doesn’t normally have that 'mac developer ID application: ’ added on to the private key. Is that normal now?

Please could you try with the version in the build folder?

It says I’m an unnotorized developer…

OK great, can you notarize that version then?

1 Like

I just compressed it into a zip and it successfully notarized.
It also says accepted in ArchiChect as well.

Do you think the copy phase is causing the issue here?
Does this mean I should build the package from the build folder, not the final destination?

The copy phase runs before the codesigning phase, so that’s likely the problem. I suspect this used to work previously because the copy step would actually create a symlink to the build folder, rather than copying the entire bundle.

It’s definitely a good idea to build the package from the build folder rather than your ~/Library folder.

1 Like

Brilliant! It says Accepted now on the package of plugs - Thanks for knowing this Apple stuff man!

edit I did notice that code stripping now causes warnings of signature failure.

You’ve saved me possibly days of work and frustration.

No email from Apple any more on success then? :grin: