Compilation error in tip for RTAS wrapper


#1

Hi all,

I am getting 6 errors when trying to build an RTAS plugin from the Introjucer, using the tip as of today (which I updated with the Introjucer, woo hoo!), with VS2010 on Windows 7. All of the errors are in the juce_RTAS_wrapper.cpp file.

Here’s the printout of the errors:

1>c:\SDKs\juce\extras\audio plugins\wrapper\RTAS\juce_RTAS_Wrapper.cpp(101): error C2017: illegal escape sequence
1>c:\SDKs\juce\extras\audio plugins\wrapper\RTAS\juce_RTAS_Wrapper.cpp(101): error C2017: illegal escape sequence
1>c:\SDKs\juce\extras\audio plugins\wrapper\RTAS\juce_RTAS_Wrapper.cpp(101): error C2017: illegal escape sequence
1>c:\SDKs\juce\extras\audio plugins\wrapper\RTAS\juce_RTAS_Wrapper.cpp(101): error C2017: illegal escape sequence
1>c:\SDKs\juce\extras\audio plugins\wrapper\RTAS\juce_RTAS_Wrapper.cpp(101): error C2017: illegal escape sequence
1>c:\SDKs\juce\extras\audio plugins\wrapper\RTAS\juce_RTAS_Wrapper.cpp(101): fatal error C1004: unexpected end-of-file found

Why no working?

Thanks,

Sean


#2

It compiles fine for me. That error sounds like you’ve accidentally typed a stray character into the file or something…


#3

I just deleted the RTAS wrapper files, updated to the latest with the Introjucer, and built again, without opening the file in question. Same 6 errors pop up. Either this is a bug with how the Introjucer brings files over, or it is a VS2010 issue, or it is a bug in your file.

Here’s the file text in question:

[code]#ifdef _MSC_VER
#pragma pack (pop)

#if JUCE_DEBUGxxx // (the debug lib in the 8.0 SDK fails to link, so we’ll stick to the release one…)
#define PT_LIB_PATH JucePlugin_WinBag_path “\Debug\lib\”
#else
#define PT_LIB_PATH JucePlugin_WinBag_path “\Release\lib\”
#endif

#pragma comment(lib, PT_LIB_PATH “DAE.lib”)
#pragma comment(lib, PT_LIB_PATH “DigiExt.lib”)
#pragma comment(lib, PT_LIB_PATH “DSI.lib”)
#pragma comment(lib, PT_LIB_PATH “PluginLib.lib”)
#endif
[/code]


#4

There’s nothing wrong with line 101 of that file - the only escape sequence it contains is the “\”, which is definitely legal, and has been working happily for several years! I’ve really no idea why you’re seeing an error there, unless something in the compiler has changed recently (I’m still using VS2008)…


#5

ah… it must be because you’ve got an illegal character in your JucePlugin_WinBag_path config setting.


#6

I haven’t entered any code/paths/whatever into the project. It is all going straight from the Introjucer into VS2010. My project has the name of the new plugin, but I’m just trying to compile the demo plugin. My PT_80 SDK is installed at C:\SDKs\PT_80_SDK, fwiw.

I’ll try to scrounge up a VC2008 install today (Express should work fine) and see if I run into bugs building with that. I’d prefer to work in VS2010, but this may be problematic for a number of reasons. I can’t even find VC2005 Express anymore, so that isn’t an option.

Also, are you going to update things to work with the new PT_90_SDK at some point?

Thanks,

Sean


#7

Try having a look in the JucePluginConfiguration.h file that the introjucer generates, and see what it’s put in there as your RTAS path. Presumably it’ll contain some illegal escape sequences (probably because your path doesn’t use double-backslashes… I may need to tweak it to automatically escape those).


#8

It looks the Introjucer doesn’t put in an RTAS path. Should it? I’ll create a new RTAS project and double check.


#9

If you’ve set a path, then it certainly should add it! Are you saying that you’ve not given it a path to use, or that it’s failing to add the one that you’ve entered?


#10

Stumbled across this same issue today. The enclosing double quotes of the preprocessor definition JucePlugin_WinBag_path must not be escaped in the VS 2010 exported file. Removing these backslashes manually solved the problem.