Const return type(!) of getProgramName and getName


#1

Greetings!

Just wondering: is it possible to remove the const from the return type of the following plugin functions? Surely it doesn’t do anything useful(?) and it inhibits move semantics.

const String getProgramName
const String getName

#2

That’s true but it would be a breaking change as it changes the function signature. I think it’s harmless enough to keep it in.


#3

Yeah, there are a handful of virtual methods that still return a const String, which I’d love to update, but which would mean breaking everyone’s code for reasons that would seem unimportant to most of our users. We’ll update them one day!


#4

Thanks so much for your replies. I look forward to a breaking update at some future time, when I can remove the comments that suppress these warnings.