Control Audio Levels Tutorial (NO SOUND)

windows

#1

Hello, I’m having trouble doing tutorials.
This tutorial:
https://docs.juce.com/master/tutorial_synth_level_control.html
It says to test it to see if you can control the level of the white noise generator but when you turn the slider up, there’s no sound. What is the reason for this. Is there supposed to be no sound or am I supposed to get to the end of the tutorial to create sound?


#2

Hi @arcadeera. Did you download the full project? I’d start by doing that first, and building the app. Then I’d go back and read through the text presented in the tutorial.


#3

By full project, if you mean this https://docs.juce.com/tutorials/ZIPs/SynthLevelControlTutorial.zip than yes, I did download it and ran it and there’s the slider and everything but when you turn it up there’s no sound. I’m thinking it might be the fact that the program doesn’t allow you to pick what output you want the sound to go to like other audio apps in juce that work fine for me. Either that or this file is broken, or I’m missing something.


#4

Works fine here on macOs. Opening the default audio device may be failing for some reason on your system. Or maybe the default device is not connected to your speakers/headphones?

The project probably should have the audio device configuration component added to allow switching the output device and other options, but that would add additional complexity to a basic tutorial…

You could try changing this line in the constructor :

setAudioChannels (0, 2);

to

setAudioChannels (2, 2);

Some devices might not like being opened without inputs. If that doesn’t help, try changing the number of outputs.


#5

I really thought that would work but unfortunately it didn’t. I tried changing it to (2,2)(1,2)(2,1)(2,0). I changed my default to speakers and did the tried all the combos again. Nothing seems to work. Projects with the audio device configuration component work for me though.


#6

Working fine for me too…


#7

A classic is, when the default selects HDMI audio, which almost nobody has speakers on. Happened on windows for me now and then. I don’t think there is a solution other than selecting via AudioDeviceSelector.


#8

Seems like I’m going to have to learn how to do that before I can start this tutorial