Cubase 5 and JucePlugin_VersionCode


#1

JucePlugin_VersionCode of my plugin is currently 0x300 and the string version is 0.3.0. Cubase 5 interprets the version code differently and shows 0.7.6.8. Is this Cubase-spesific or do all VST hosts do the same?


#2

Well, AFAIK there’s no actual VST documentation for that version parameter to explain how it should be used - it’s just an integer, and I guess they’re interpreting it as decimal, though hosts may choose to display it differently.