Cubase 9.5 Midi timing bug


#1

Hey everyone,
I ran into a strange bug:

In the JUCE process block, all MIDI messages came in with a timestamp of 0.
After getting the bug in a code I was working on, I easily recreated the bug using some of the examples.
Try building the arpeggiator plugin example (mark it as a synth/wants MIDI input), and have a breakpoint only when notes come in in a timestamp other than 0.

Now, here’s the weird thing: It only happened in Cubase (tested on version 9.5.21, Mac OS Sierra) in VST3.

When I tried debugging the same code in Reaper (VST3) and Ableton Live 10 (VST2) timestamps showed up correctly.

Any idea what to do? Is it a Cubase bug?
Eyal


#2

To shed some more light on this issue:
If I play a recorded midi track in Cubase, it does give the correct timestamps, but as I’m recording MIDI, it will send all the events with a ‘0’ timestamp.


#3

It’s not a juce problem, we can only pass on the timestamps that the host sends, and clearly it’s just not bothering to attach timestamps to the live data.