Demo doesn't select default audio output channel (Windows Audio)


#1

Instead it chooses the first from the list (screeshot), which looks like sorted randomly. 

The "Lautsprecher" is the same i choose in Windows, the right one.

 

 

 


#2

Hmm, the order is returned by the win32 enumerator, but there's already code to check for the default device and move it up to be the first.. It's in juce_win32_WASAPI.cpp line 1404. It has always worked fine for my machine, but you seem to have a pretty crazy set of devices there!


#3

Not uncommon for people who use several computers, e.g. for orchestral composing. I also have a MADI setup (64 in/out) connected with 5 slave computers. Lots of people (incl. myself) are moving to a single DAW, with at most 1-2 slaves. Which also reduces failure rates :-)


#4

This is a result of the input sample rate being different from the ouput.  It prevents the default output being selected.

I disabled input on the demo and the default is selected straight away.

My input is 32kHz from a webcam mic and output is 48kHz.

When I use the RME with ASIO default selection also works.  It has matching in/out sample rates.

With the input off the buffer size default cannot be selected, which makes sence.

So for default channel selections on all devices be sure your input samplerate matches your output samplerate.