Develop: App subfolder


#1

Hi - to get a fix I’ve just pulled the latest version develop. Only my windows executable now builds into a \App\ subfolder…??? What’s that about - is it deliberate? Is there some way of getting it put back where it used to be, or should I use the ‘Binary Location’ feature?

it’s broken my installer scripts …


#2

I think it’s this - it’s a breaking change…would be much better if it was something you could opt into. Also -with the latest version of the develop stuff something has seriously broken Resharper. All the symbol lookup stuff and paths don’t work any more - all the JUCE stuff appears to be highlighted in red. It’s probably a Resharper problem - but it was working fine till I pulled the latest develop stuff.


#3

Hi Jim, have you tried clearing your component model cache?


#4

I started a clean project to check…maybe the component cache is not project specific. But I think it’s something in JUCE changes that has tickled a slightly flakey resharper…

Probably JetBrains need to look at it. But it’s very annoying.


#5

Right, having just completely some git trickery, I’m back at the commit before the App subfolder appeared, and Resharper is back to normal:

And I’ve done a git cherry pick for the first time to apply a change I needed, which was rather cool…

I don’t know if the JUCE team want to pick up the Jetbrains issue or shall I put a ticket in?

Though changing JUCE so existing projects suddenly start having binaries created in new locations isn’t ideal. It breaks a lot of fiddly things.


#6

I had a similar problem a few weeks back and clearing that cache fixed it - just can’t remember if it was on the machine with Resharper or not.


#7

I don’t even know if resharper uses that cache… I have intellisense turned off.


#8

I forgot all about this and bought Resharper C++ today which was a bit dumb :grimacing: - anyhow, I can confirm the problem.

Jim let me know if you lodge an issue with JetBrains and I’ll upvote it. Also please let me know if you figure out any workarounds.


#9

You’d better lodge the issue Andrew, I’ve just reverted to a previous version of JUCE for now. We are trying to get some stuff launched and I’ve got enough of my own bugs to panic about for the next couple of weeks…

:slight_smile:


#10

OK, here it is: https://youtrack.jetbrains.com/issue/RSCPP-19529


#11

Have added my thoughts to the ticket :slight_smile:


#12

Fix in next Resharper C++ release and EAP build available (see youtrack issue linked above).

Workaround is to include header files in the project.


#13

Super good news that is