Experimental JUCER can't create Static Library projects


#1

[Yes, I know I owe Jules an email “in the other window” but wanted to report this before I forgot…]

When you create a new project in the experimental (“build”) Jucer, you get three choices - GUI Application, Console Application and Audio Plug-in. However, once you’ve created the project, you now have four project types: Application (GUI), Application (non-GUI), Audio Plug-in, and Static Library.

Not a big deal - if you need to create a static library, just change the project type after you’re done. At least, I hope that works, I’m trying it right now.

Looking at the code, the fix is non-trivial - there needs to be a new type of NewProjectWizard for Static Library.


#2

Hmm, I can’t really get a static library to build.

I can’t select any JUCE linkage except “Not linked to JUCE” - and so the JUCER won’t generate JuceLibraryCode/.

Because I’m using flags other than the default AppConfig flags in my JUCER project, I need the JUCER to generate JuceLibraryCode files, as it does correctly for my apps.

Well, this seems to be a new feature anyway! I’ll keep watch on it.


#3

Yeah, the static library option is basically what I added so that I could use the jucer to generate the actual juce project.

I haven’t tried using it to create a static lib that uses juce, but it should be possible. Your static lib doesn’t actually need to contain any juce source code, it just needs to include juce.h - it’s the app that incorporates it that is responsible for actually including or linking to the guts of the juce library.