Extermal Plugin parameters mismatch bug with some VSTs

I found a bug pertaining to external effects parameter automation. This is present in my own tracktion engine project, but it is easiest to observe in Tracktion Waveform. At first glance, it looks like a VST bug, but other DAWs including Reaper and BitWig Studio work correctly.

Here are the steps to reproduce:

  1. Open an empty Tracktion Waveform edit
  2. Add an instance of “U-he Zebra 2” VST3 plugin to an audio track
  3. Create an automation lane for “the FM Depth” vst parameter,
  4. Add some breakpoints to the FM Depth Automation Lane
  5. Click the Play button
  6. Open the Zebra 2 GUI, observe the Filter 1 resonance

Expected behavior: The FM Depth knob in the GUI updates according to the parameter automation

Observed behavior: The “Filter 1 resonance” knob changes instead.

At least 90% of the parameters are mismatched like this.

Not all VST exhibit this behavior, but U-He Zebra 2 VST3 parameter automation does work correctly in Reaper and BitWig Studio.

The VST2 version of U-He Zebra 2 works correctly, but it is difficult to use VST2s in tracktion_engine projects due to Steinberg’s licensing choices.

I am on Mac OX 10.14.6 (Mojave), and running Waveform 10, and U-he Zebra 2.9.0 Rev 9436 (64 Bit)

Any chance of getting this fixed?

Before I spend some time getting hold of a copy of Zebra and debugging this. Can you verify it’s a bug with Tracktion Engine and not something on the JUCE level?

The easiest way to test would probably be to build the juce Audio Plugin Host and load the generic UI, move the parameter in question and see if that moves the parameter in the plugin UI.

If that’s working as expected, it’s probably something to do with our parsing of parameters but it’s odd it would only happen with some plugins…

@dave96 Thanks I just tried this, and your guess is correct. The bug still occurs in the vanilla juce AudioPluginHost project. What’s the best way to forward the issue to the JUCE team. Should I make a github issue?

Either that (if you have a fix at the ready) or post on here.
I’m not sure how closely they monitor the Tracktion Engine threads so probably a good idea to start a new thread in the “Plugins” category.

The JUCE team read all the posts :slight_smile:

Thanks for the bug report. We’ve fixed it:

2 Likes