File 'x.h' from the precompiled header has been overridden


#1

When using the Projucer, I keep receiving the compilation error "file 'x.h' from the precompiled header has been overridden". Once this has happened, the only way to get the JIT engine going again is to do "Clean All" which requires a full recompile and slows things down a lot. Some of the time this error shows up every 30 seconds or so. It seems that often the files which throw the error, are all the currently open header files under the "Window" menu in Projucer.

What does this error actually mean?

What can I do differently to avoid it?

Repeatedly receiving this error and having to do a full recompile is rather mitigating the fun & productivity enhancement of having the JIT engine.


#2

That's a good question - we tried to figure it out a while ago but never got to the bottom of it! Seems to be something in clang that's detecting some kind of mismatch between precompiled headers and new code, but we couldn't find a way to automatically avoid it. Will hopefully have time to try again soon..


#3

any updates to this? I have this happen alot. I have to restart ProJucer, Save All, Clean, then it’ll build properly.


#4

You shouldn’t have to restart projucer, just cleaning does the trick in my experience.

But no, sorry, we still didn’t get to the bottom of that one! Will aim to have it done for the next update!


#5

I get this quite often but I find if I’ve launched Projucer, let it fail as it often seems to at first with this error, do a clean-all, let it complete the build and only then load and start compiling stuff in XCode it’s fine for the rest of the day. It’s a little bit of an annoyance, but the tool is so useful it doesn’t matter really.


#6

i’m getting this too now. I’ve tried the clean-all but no avail


#7

Now it’s happend to me to :frowning:
Any change?