[fixed] Problem with new folder tree?


#1

Is it me (and I apologize if it’s the case) or have there been changes in the tree of folders which cause problems when creating a new project with Projucer (AS only) ?
I downloaded the latest tip, compiled projucer with that, and when I create a new simple GUI project and try to compile it with Android Studio it can’t find the juce modules anymore (used to work with no problem before 4.2).
I tried copying locally the modules, or using the folder in the JUCE folder (no complaints in Projucer, it does find them), both show the same problem in Android Studio. Obviously, this works for other platforms.


#2

What OS are you using? Windows, Mac, or Linux?


#3

Mac 10.11.4


#4

Meanwhile I updated AS to latest version (2.1 beta 2) and I get the attached error. Cannot get further than the gradle window… VERY annoying…

EDIT: For this one the new SDK probably deleted the old NDK folder so please ignore it (I will confirm later).
EDIT2: yeah I solved this problem by re-installing the NDK. However, the problem described above remains.
Please help. Thanks.


#5

So can someone confirm that the latest tip (at least) does not compile simple new project from Projucer in Android Studio ? Or that it does and that I’m just too “distrait” ?..
Thanks


#6

Yes I can confirm that the latest update seems to have broken Android Studio compilation, and I’ll fix that as soon as possible!


#7

Ah ! ok thanks.


#8

We fixed the Android Studio exporter on the newest tip, and successfully tested it on all platforms.

Please update to Android Studio 2.1 Beta 3 and the newest build tools, re-build the Projucer and try again. Everything should work now.

The only catch is that the clang toolchain for Android seems to be broken on OS X, you have to use gcc for now (I made it the new default setting). See this post.


#9

Yep, seems to work. Thanks !