InAppPurchases::Purchase::purchaseTime is a
juce::String but there is really no reason why it shouldn’t be
juce::Time instead. It would be much more useful.
juce::Time has methods to compare different times, for instance if one needs to determine how many days have passed since a product (such as a free trial) was bought.
Converting a Time object to a String is trivial (but not so the other way around!). In fact, the native classes of InAppPurchases convert from Time to String internally just before returning the value, so implementing the change would be very easy.
And I think it would be fine if it’s a breaking change since a fix would consist in just adding
.toString (true, true, true, true);
I know that this has been mentioned before but it is such a simple and sensible change that I thought it would make sense to make a feature request.