fromRGBAFloat fix


Maybe its better to also rename a function when you change the parameter types (even its a fix)
background: the actual fromRGBAFloat-fix works different, and you may didn’t get a notice because the int is automatically converted to a float (but the function has a different range 0…1 instead of 0…255)


Yes, sorry, that’s true… Annoyingly, the uint8 parameters were actually a typo, and it now looks the way I originally intended it to be! I was a bit annoyed when I noticed what I’d done there, and grumpily thought I’d just change the params.

TBH I suppose I could rename it “fromFloatRGBA” which sounds just as good and would stop anyone else getting caught out.