Greetings + keystrokes->VST


#1

Hi All,

I’m a newb to JUCE. Still learning the ropes but so far things are good.

Building JUCE from the tip via git, I get an issue with the AudioPluginHost example: I can’t seem to pass keystrokes to the VSTPlugins (even the standard VSTGUI CTextEdit field, the problem persists on other VST’s besides my own, and everyting seems fine on Windows).

This seems like a new issue as it was OK in 1.46 and 1.5. However as irony would have it I was running into a different issue in 1.5 (VST Frame was drawing blank, well it would draw for a split-second and then re-draw blank), so I went to the latest.

I’m trying to embed a VST window inside the GraphDocumentPanel which is probably complicating things, I thought I was doing something stupid (which is still a possibility) until I realised that the AudioPluginHost example now seems to exhibit this behavior as well. Can anyone confirm?

If anyone has any suggestions I’m all ears :slight_smile:

thanks
Steve


#2

Still stuck on this…

a normal CTextEdit control will not accept keystrokes. Standard dialog windows will.

It tries to get keyboard events with (in the VST):

EventTypeSpec eventTypes[] = {{ kEventClassWindow, kEventWindowDeactivated },{ kEventClassKeyboard, kEventRawKeyDown }, { kEventClassKeyboard, kEventRawKeyRepeat }, { kEventClassControl, kEventControlDraw} }; InstallControlEventHandler (textControl, CarbonEventsTextControlProc, GetEventTypeCount (eventTypes), eventTypes, this, &gTextEditEventHandler);

However gTextEditEventHandler kEventClassKeyboard events never seem to get called when using AudioPluginDemo. Keystrokes are still going to the host.

Anyone have a tip / workaround / suggestion of something to get this to work?
This works fine in every other host. It worked in Juce 1.4; and I’ve tried many things so far with no success.


#3

TBH I’ve no idea how VSTGUI handles keystrokes, but they use the old carbon APIs, and when you start mixing up carbon and cocoa nothing’s ever simple (Juce 1.4 was carbon, which explains why it might have behaved differently). I’d take a look, but am absolutely snowed under with other stuff right now, sorry!


#4