How to stop iOS using 16kHz sample rate when bluetooth device is connected?

My app uses a 16kHz sample rate when bluetooth devices are connected (JUCE 5.4.4). Is there a common method of stopping this? I’ve looked at the topics where it is stuck at 8kHz but these seem a little outdated now.

Console output from iPad:
set kBluetoothAudioDevicePropertySCOIsEnabled : false, sample rate 16000.000000

Do you (maybe accidentially) open an input channel? Normally sound input from a BT headset is only possible in phone mode, which is usually 16kHz SCO. But it’s a bit strange then that the console message says SCO is disabled.

Yes, I am trying to open an input channel but I’m trying to open that using the phone microphone instead of the headset. The amount of phones that lack physical headphone ports these days make doing this a necessity according to the people I’m working with. Do you know a way of doing this?

Thanks