Introjucer not automaticaly creating BinaryData.cpp file


#1

Hi all.

When I am adding a resource file to my project (i.e. .png, .txt ...), the Introjucer not automaticaly creates the BinaryData.cpp file into JuceLibraryCode or anywhere else.
I just check the  "Add to Binary Resources" but nothing happens.

I am using now the BinaryBuildel.exe for a temporary solution.

My OS : Windows 8.1 64-bit
Juce modules version :  3.1.1

 

Any suggestion please?

 

George

   


#2

First time I've ever heard of that happening.. Perhaps step through ProjectSaver::writeBinaryDataFiles() and see what happens.


#3

The Juce version I had,  was downloaded from "GitHub/Download Juce for Windows".
Now I downloaded only the source code from "GitHub/Download Juce source code from GitHub" and I natively built a release version of introjucer.

After that, everything goes ok !

George 

 

  

 

 


#4

An other problem suddenly emerged in the Introjucer. 

The "Available version" in the "Config/Modules"  remains blank (-).
Also when I press the button "Download and Add a module" I get the message "Couldn't contact the website".

As I saw, the loadFromWebsite function returns a nullptr input stream, while the target URL seems ok.

I tried with other URLs but the result was the same.

Any idea?

 

George

 

Edit :  ...and ultimately trivial but annoying as a mosquito: the splashscreen, does not show its title. It shows only the image.


#5

1. I've just tested adding a binary resource to the Introjucer and it works for me (on Windows 8.1). Remember that you need to do "Save all" and "Save Project" for the changes to take effect. Also, make sure to close the Visual Studio project and open it again. My usual workflow is to always close the visual studio project when working in the introjucer, then saving all changes and clicking on "Save Project and Open in Visual Studio". This way Visual Studio will always be up-to-date.

2. I've had the same issue with the could not connect when my windows firewall is blocking the introjucer. Normally, Windows will warn you if this happens but for some reason the Introjucer did bring up a warning for me on Windows 8.1. I needed to specifically unblock the Introjucer from the firewall. Try briefly turning off your firewall and check if it works.

 


#6

1.  The point was "need to do "Save all" and "Save Project" for the changes to take effect", at the first time, in order to see the BinaryData.h and .cpp in the Files tree.  Ok, I never have open the Introjucer and my IDE at the same time.

2. In my case I had to adjust both the Windows 8.1 and the Norton Internet security parameters.  So, the Introjucer works properly now.

BTW : Norton Internet Security, deletes the Introjucer.exe every time is executed, until I add Introjucer.exe to its exception list. Probably because the introjucer scans keyboard typing.


#7

Edit :  ...and ultimately trivial but annoying as a mosquito: the splashscreen, does not show its title. It shows only the image.

Which splashscreen? I wasn't aware that the introjucer had a splashscreen..?


#8

My project's splashscreen. 

        Splash = new SplashScreen("Welcome to the Metronome kit",
                     ImageFileFormat::loadFrom(BinaryData::GrannysAudioTradeMark_png, BinaryData::GrannysAudioTradeMark_pngSize),
                      true); 

When it appears, the title does not appear. 


#9

Why/where would you expect the title to appear? It's not a DocumentWindow, it's just a plain rectangle that displays your content. Most people will have their title as a logo or large graphic element rather than wanting it at the top, but you can draw it there yourself if you like.


#10


Ok Jules. It is my misunderstanding.
Carried away by the splashscreen constructor, which has a "string& title" as the first parameter.
Sorry for the time you spent for it..