JUCE_COMPILER_SUPPORTS_LAMBDAS ?


#1

I'm not quite sure how to get this flag turned on. From juce_CompilerSupport.h it looks like 
_LIBCPP_VERSION has to be defined. Do I need to manually define this in the Introjuicer for my project?


#if __has_feature (cxx_lambdas) && (defined (_LIBCPP_VERSION) || ! (JUCE_MAC || JUCE_IOS)) 
 #define JUCE_COMPILER_SUPPORTS_LAMBDAS 1 
#endif

#2

fixed the issue by updaing my "OSX Deployment Target" setting to 10.9. Looks like anything lower won't work?


#3

So to clarify, if I want to use the juce classes that use lambdas, all my binaries must have a minimum OS requirement of 10.9?


#4

No, 10.7 should work. You may have to select libc++ from the Introjucer as well


#5

Ah, I thought I had tried the various combinations of "C++ Language Standard" & "C++ Library" but updating them did the trick :)