Juce Demo Plugin AU can't get stereo input signal!


#1

As a sanity check I went back and re-built the Juce Demo Plugin AU, and it also can’t get a stereo input signal even though in JucePluginCharacteristics.h I have dutifully ensured that

#define JucePlugin_MaxNumInputChannels 2
#define JucePlugin_MaxNumOutputChannels 2
#define JucePlugin_PreferredChannelConfigurations { 2, 2 }

Note: I removed the {1, 1} channel config option. With only {2, 2} left as an option, the host should only be giving me stereo in and stereo out. Right?
I tested this in both AU Lab, and in Ableton Live 6.0.7 on OSX 10.4.11.

It seems like such a fundamental issue as this should have been spotted before by someone. Any info on this will be greatly appreciated! Thanks!


#2

Hmm. I’m a bit confused, then - you can see in the SupportedNumChannels function where it returns the numbers of channels, and there’s no option in that structure to specify whether it’s a pair of monos or a stereo channel


#3

Sorry if I didn’t explain thoroughly enough.
To duplicate in AU Lab, create Master Out with any two stereo channels as the output. Then Edit->Add Audio Input… and select a stereo pair of channels as the input. In the “Audio Inputs” column you will see two little VU meters at top that animate with your stereo input signal. With no effects inserted you’ll see that the two larger VU meters at the bottom of the same column also animate with the signal. Now insert the Juce Demo AU. At this point, the two VU meters at the top still animate showing the input signal as before, but the VU meters at the bottom only show a signal present on the left channel. Right channel is completely dead :cry:

In Ableton 6.0.7 it’s even weirder. After instantiating the Juce Demo AU on a stereo audio channel as an insert effect, you can see that the channel’s output does have signal present on both left & right, but it’s the same signal on both channels because the VU meters remain perfectly locked to the same level even though the input vu meters show different levels on left & right.


#4

No, sorry, I did understand what you were explaining - I meant that I don’t understand why it’s happening, because unless I’m missing something obvious, I can’t see anything in the code that lets you specify whether a channel is stereo or not…


#5

If i insert the VST juceDemo in Live 6.0.7, OSX 10.4.11, stereo
tracks goes to mono, same for a plug-in im working on.
But they both work normally in Cubase 4 and Live 7 so theres definately
something odd going on with juce VST + v6.0.7, AUs in 6.0.7 are ok.


#6

Have you tried setting the channel properties to stereo?

bool XXXX::isInputChannelStereoPair (int index) const
{
return true;
}

bool XXXX::isOutputChannelStereoPair (int index) const
{
return true;
}


#7

nice one - that worked!