Jucer strange behaviours


#1

i’ve started using jucer again, on linux.
i noticed that the subcomponents grouping options are always disabled, is this wanted ?
also when i export the cpp files, they are Unicode (utf-16) cause if i open’em from my text editor (which defaults to utf-8) the number of bytes is doubled (with a space between each character)… ??? this way i have to open up the generated file and save it with utf-8 encoding every time i export the jucer component. could be gr8 if the jucer lets you specify the encoding you want to export the generated component files…


#2

subcomponents grouping options?.. sorry, not sure what you mean…

Someone else asked today about the encoding of jucer files, which I said was ascii, but in fact it’s not, I was looking at an old file, but the recent versions now save as utf-16 with header bytes. It’s done in JucerDocument::writeCodeFiles(), so you can tweak it if you need to. (Adding a format option would be a good idea, you’re right)


#3

with subcomponents grouping i mean, you select 2 subcomponents from the subcomponent tab , then they become with the yellow border you can drag and move togheter, then you can group the 2 components and trat them like being only one ? (i saw that some versions ago)… there is also the menu that says “Group components” or something…

the encoding selection i think is a must have, probably along the properties of the jucer component…


#4

Ah yes. It’s quite a lot of messing about to add properties for multiple selections, but would be useful. I’ll do it eventually!


#5

mmmh i was just not thinking about this… eheh… i was just saying that the menu with “Group selected” label (or whatever) is always greyed out !
you’re going more forward than me ! :wink:
anyway your idea could be really cool…


#6

Oh, I see. “Group selected” is only for grouping graphical objects, not components.


#7

ahhhh, i remember correctly so, i saw the grouping somewhere… but i was sure it was about grouping components, not graphical objects… must been too drunk so :wink:


#8