Jump to definition not working XCode 15.3

just install XCode 15.2 until this is resolved

2 Likes

I had this problem and found a workaround: Move the Source directory in Xcode from

ProjName / ProjName / Source /

to

ProjName / Source /

and delete the now empty ProjName “folder” (or is it a “group”) in Xcode. Since Projucer generated this, there may be some bad interaction between Projucer and the new Xcode. This is consistent with CMake bypassing it.

I’m on:
Mac OS Sonoma 14.4.1 (23E224)
Xcode Version 15.3 (15E204a)

3 Likes

None of my projects look like that…

Macintosh HD / username / juce_projects / Company_Name / Client_Name / Project_Name / (Project_Name files)

Rail

I had exactly this problem, with a blank Audio Plug-in project straight from the Producer, downgraded to Xcode 15.2 and everything works again. Very irritating, wasted a lot of time on this.

Same here, xcode’s intellisense and buggy highlighting is getting to be quite infuriating…

You’re right this worked! Thanks a lot! :smiley:

I found my own workaround to that issue. It is little bit pain in the ass but it works.
I am on Sonoma 14.4.1 and xCode 15.3
Issue happens for me after I launch the xCode project from Projucer. So after I open xCode project directly from Projucer I perform following steps:

  1. close the xCode project
  2. in the Finder go to myProject.xcodeproj and right click on it and choose “Show Package Contents”
  3. remove folder called “xcuserdata” and remove file named “project.xcworkspace”
  4. go again in finder to myProject.xcodeproj and open it by double click

After such steps almost all described issues disapper.

i’m just hoping it’s fixed in 15.4

In my report I see:

Recent Similar Reports:None Resolution:Open

So anyone else can try and ping apple and mention FB13702565, it might be helpful.

Worked for me!

I’m not 100% as I gave it a very quick-spin.
But it seems Xcode 15.4 indeed resolves this (Xcode 15.4 / Sonoma 14.4.1)

3 Likes

Yes, agreed, so far so good in 15.4

1 Like