mouseWheelMove


#1

Thought i’d beef up my XYZControl plugin with some exciting new features, and i’ve encountered a slight problem.

The mouseWheelMove(…) function is not getting called in my control component. After ages of trying to debug it, i discovered that closing the editor window and reopening it suddenly enables the callback.

This was tested in energyXT (i don’t have any other host installed at the moment). Any ideas?


#2

Wheel movements only go to the focused app - does it make a difference if you click on the plugin to focus it? Have you tried setting the editorRequiresKeyboardFocus flag to true?


#3

well, the purpose of the plug is an XY controller, so i have to click on it to check it :smiley: so no, clicking doesn’t make it recieve the mouse wheel callback. My template projects always have editorRequiresKeyboardFocus set to true, so that’s not it.

close the editor and then reopen it, and it’s fine.


#4

Well you could stick a breakpoint in the windowing code to see if any wheel messages are actually hitting the juce window, but I suspect this will be some kind of host weirdness.


#5

hmm… tracktion does it too now, when both eXT and T were fine with XYZ before. i’ll make a barebones VST plugin without anything in to see if it’s a problem with the newer framework.


#6

I was wondering if this problem has been solved? My app stops receiving mouseWheel callback, and its unpredictable?


#7