Nastiness in the ALSA wrapper


#1

hey guys,

I’m using JUCE on linux and there is a crackling/gliching problem with it. It occurs only if ins and outs are both turned on, and strangely it disappears with really low bufferrates (but not all, just certain…). Its independent from the soundcard (same glitching with two different soundcards).

Jules said here the following:

Blockquote
Hmm, that’s interesting. Because the inputs and outputs are separate, there’s some nastiness in the ALSA wrapper to try to synchronise them, and that could be the culprit in cases where the input and output devices have a tendency to drift. I’ll try to have a look into this…

I think this is really a problem, because it makes some tasks useless on linux. The thing is, ardour e.g. runs without those problems on my machines, so there is a prouf that it should be possible on linux to have a smoothless alsa integration…

Any ideas on this?

A next step could be to look into the ardour code, use its alsa stuff and try to integrate this in JUCE but this seems like a really giant project I dont have the time for…

Any ideas on this?

Regards,

equinox


#2

Your issue is missing some information about your system. I had problems on Ubuntu 17.04. Now on 18.04 everything is working fine.


#3

yeah you’re right. I’m using Arch Linux, I will the issue also later with ubuntu!


#4

Ok I tested it with Ubuntu 18.04 and had the same issue - glitching with the test tone when both inputs and outputs where active, a clear tone when I disabled the ins. The outs are actually called as same as the ins, what is making me wonder a while…
I used a Fast Track Pro (yeah old stuff…) and a behringer uca-202… with a zoom u-24 there its not possible at all to select both ins and outs… :confused: