New class: RandomAccessFile


#1

I’ve created the interface and definitions for RandomAccessFile. Jules if you could give them a quick review and let me know what you dislike and what you absolutely hate, I will make the necessary adjustments and continue:

juce_RandomAccessFile.h
juce_RandomAccessFile.cpp

Note that I have consolidated all of the native operations into the static members, these will go into posix_SharedCode.h and juce_win32_Files.cpp (I haven’t done that yet). Is this ok?

Anything you want me to rename or change before I continue? I’ll be back in 90 minutes.