New Jucer, include juce directly


#1

The option to “include Juce source directly, split across several files” doesn’t seem to work. I get a compiler error saying “cannot open file ‘jucelib_static_Win32_debug.lib’”, am I missing something?


#2

Maybe you’re including juce.h directly somewhere in your own code instead of using the header files that the jucer generates for you?


#3

Bingo. One other thing. When I include resource files in my jucer project and they show up with a little icon beside them when I open them in VS Express and don’t seem to be included in the build? I’ve attached a screen-shot. Is there something I must do to make it work other than just including the files in the jucer?


#4

That’s how it’s supposed to work - the files get built into the BinaryData files that the jucer creates. The items in your VC project are just there to show you what was used, they’re not supposed to actually be compiled by VC.


#5

I see. Thanks for that. I must say I’m getting great mileage out of the new jucer. It works really well. I’m about to try some cross platform projects and see how they go, hopefully there won’t be too many issues.


#6

I’m certainly enjoying developing the new Jucer whilst using it to create its own project files in a terribly recursive way…


#7

I get the same error. And I didn’t include any header myself. In fact I didn’t programme a single line of code. Just tried to open the project in VC++2008 and it fails compiling saying: “Now where did you rookie put jucelib_static_Win32_debug.lib?”

Was never so lost in 15 years of doing IT. Puzzled.


#8

Alright. Now it works.
Sadly I cannot tell why. Just tried this way of creating a project one more time. And this time it worked. Sorry about this pathetic post. Just telling the facts.
My main problem
http://www.rawmaterialsoftware.com/viewtopic.php?f=3&t=5400&hilit=jucelib_static_Win32_
however, remains unresolved.
Cannot include components created by the Jucer with the VC++2008 project compiling it. jucelib_static_Win32_debug.lib missing.