No Midi Input Device in MidiRecordingDemo on Windows


In the MidiRecordingDemo I don’t see any Midi-Inputs if I click on the “I”-Button.

What I haved tried:

  • I changed in the EditViewState: showMidiDevices.referTo (state, IDs::showMidiDevices, um, true); But there is still no Input showed up.

  • I changed in the Utilities.h in the showAudioDeviceSettings (te::Engine& engine) Function: new AudioDeviceSelectorComponent (engine.getDeviceManager().deviceManager, 0, 512, 1, 512, true, true, true, true)); for showing Midi inputs and Outputs in the Settings. Now, my Midi-Keybords is showing up in the settings, but I can not choose any Inputs in the Track.

What do I missing here? How can I connect the Midi-Input, which is showed in the settings to a track?

I just fixed this, it’ll take a few hours to clear ci and appear on GitHub.

The second time you run the demo, createTracksAndAssignInputs wasn’t getting called.

This loop needs to run:

        auto& dm = engine.getDeviceManager();
        for (int i = 0; i < dm.getNumMidiInDevices(); i++)
            if (auto mip = dm.getMidiInDevice (i))
                mip->setEndToEndEnabled (true);
                mip->setEnabled (true);
1 Like

Thank you very much. This works like a charme!