"No package 'freetype2' found" When installing FRUT

Not sure where is the right place to ask, but I’m trying to use FRUT in a Ubuntu container using mingw and when I try to install it with cmake .. -DCMAKE_INSTALL_PREFIX="../prefix" -DJUCE_ROOT="../../JUCE" I get this error:

-- Checking for module 'freetype2'
--   No package 'freetype2' found
CMake Error at cmake/tools/juce_gui_basics.cmake:74 (message):
  pkg-config could not find freetype2
Call Stack (most recent call first):
  cmake/tools/juce_gui_basics.cmake:80 (use_package)
  cmake/tools/CMakeLists.txt:85 (include)

-- Configuring incomplete, errors occurred!
See also "/mnt/FRUT/build/CMakeFiles/CMakeOutput.log".

I’ve already tried running apt-get install cmake libfreetype6-dev libfontconfig1-dev xclip; and also pointing to my freetype2 library in the following environment variables:


And I still get the same error. I’m able to install FRUT without problems in my Windows machine locally, but this happens when I try on a Ubuntu docker container (which should be the same as a native Ubuntu machine).

I guess it’s libfreetype6-dev what’s missing. Here have a look:

Very often you need the *-dev version of a package which contains the source code.

I’ve already tried installing all the dependencies (including the -dev and libfreetype6-dev) and still get the same error.

Issue solved by modifying the PKG_CONFIG_PATH environment variable and pointing to the freetype .pc file. (in my case /usr/lib/x86_64-linux-gnu/pkgconfig)