Ok I am perplexed, different output when using Plugin Host and DAW


I have just noticed a very strange inconsistency in plugin’s output depending on whether I run it in the JUCE Audio Plugin Host, or Ableton, my DAW of choice. Screenshotted below is the output. In each cases I am using my Clipper plugin (left) as an oscilloscope to monitor the output from the synth (right). As you can see when I run it in ableton, the distortion provided by the “drive” section produces a very strange slope that is not what I intend at all. I simply have a cubic clipper, a tanh clipper, and a sine fold. None of which should be producing that slope.
When I run it in the Audio Plugin Host, the output appears perfect and produces the expected output for all three algorithms.

This is the same binary, only running in the plugin host.

Has anyone encountered anythin like this?
I am using an array of dsp::WaveShapers do perform the distortion and I am very confident that the functions used are correct.

Many thanks

Do you see the same thing with the same settings? I see the settings are not the same in those two screen shots. One uses tanh and a higher drive setting, and one uses cubic and a lower drive setting.

yes with the same setting the same thing happens.

Your plugin could have cycled through different sampling rates, before reaching the final setup. But that is just one idea, like you identified, calling prepare() is necessary in any case.

the slope of the ‘flat’ part of the faulty output indicates that it might be being high-pass filtered, e.g. a "DC Blocker’. Is the signal going through the DAWs EQ? mayby?

Ableton Live has built-in gate in the master output. You can disable it by adding the following lime to Ableton Live options.txt file: