OS X 10.6 support survey


#21

I agree although your 0.01% figure is way off. Official marketshare is still 1.5%. Also… those of us who have been doing plugins for a long time (I started when 10.3 came out…) have long-term customers with a higher chance of using old software.

Still I agree JUCE should drop 10.6.8. support, but ideally not in between master branch version releases.

I don’t build on Linux, but I think requireing libc++ might have some consequences for that as well?


#22

It’s not a libc++ requirement, a fairly recent libstdc++ will do the trick


#23

Earliest we target is 10.7, drop it!


#24

Maybe worldwide installation base unrelated to the audio-market is 1.5%. We honestly don’t care at all about some outdated computers in China that have no interested in our products. Why would we?

We have almost 70,000 NEXUS2 installations out there, and about 7 or 8 tickets that ask for an installer that works with 10.6. Some customer specifically updated their OSX version to continue using NEXUS.

We’ve been doing plugins since January 2001. We had customers on OS 9. We know all about long-term customers. That doesn’t mean we shouldn’t update our systems, SDKs etc. regularly and encourage our customers to keep up to date, too.

OSX 10.6 was released in August of 2009. Updates are free nowadays. Except ancient hardware, there is not a single valid reason NOT to update.


#25

From our web-site’s analytics, 0.5% of Macintosh using visitors are on 10.6, and 10.5 comes close to the mentioned 0.01% figure with 0.02%.
Of course those numbers don’t necessarily reflect users. I’d guess many might be browsing on their laptop’s and tablets and not necessarily on their work machine. So actual percentage of users on 10.6 is probably higher than that.


#26

Here at UVI, our minimum is 10.7


#27

Thank you for all the feedback.

Based on your responses I’m going to propose that we will make JUCE 5.3 (the next major release) the last version that’s compatible with 10.6.


#28

What SDK will that use?


#29

I would suggest that you use the most modern SDK possible, but target 10.7.

For example I’m using the 10.13 SDK, targeting 10.7, and using the “LLVM libc++” C++ library in the Projucer settings. This allows access to most (maybe all - I’ve not done a comprehensive search) C++11 features.