Plugin passes AUVAL test but doesnt show up in logic pro

Hi all,
I built a plugin using JUCE 7.
I tried building it on my m2 mac and also on a couple of older intel machines.
On the m2 I checked all the architectures in projucer and targetted 10.13 in XCODE.
I built an “any mac” version.
The plugin opens in mainstage , cubase, reaper and standalone on my machine.
I built a windows version which seems to work fine in windows reaper and standalone.
A couple of musician friends asked for it. They have intel macs and OSX 10.13 or 10.14
The plugin passes AUVAL but does not show up in logic pro.
It’s a real musician oriented plugin ie for people that “can play an instrument” whatever that means.
Usually those sorts of people use logic not ableton live or reaper or something else.
It’s a shame using apples build tool I cant get apple’s main piece of music software to find it.
I dont really want to buy logic pro myself.
What should I do.

Has the plugin properly code signed and notarized? If so, is still not showing up after a reboot?

1 Like

No not signed.
I might go through that and pay apple and see if it helps.
Do I understand if I just want to send around component files or vst3 files without an installer that they can just be signed and not notarised ?
I did find a logic demo for my m2 mac and got it to load.
I will report back .

Logic does not require signed/notarised plugins

1 Like

It certainly loading on the logic demo here running ventura on an m2 also mainstage.
I may have bypassed security measures on this computer at some point.
I built it again setting it to “release” maybe users on OSX 13 and logix will have more luck

False. I have to sign and notarize plugins i send to beta testers, otherwise they won’t be loaded. Same if I want to test them on a different mac i own. They will load in your dev environment, but not elsewhere

My bad, I thought on his machine

Today a user managed to open the plugin in logic on his machine. I made a new “release build” . Not sure what i did differently to make it work. it is not signed at this point. i gave apple $100 still waiting for them to “process” the transaction. i have had that account for years never use it.