Pro Tools and Multi Stereo Outputs

I try to make a plugin with a required main stereo output and optional 7 additional stereo outputs.

I do:

   : AudioProcessor (BusesProperties()
                     .withOutput ("Output 1", AudioChannelSet::stereo(), true)
                     .withOutput ("Output 2", AudioChannelSet::stereo(), false)
                     .withOutput ("Output 3", AudioChannelSet::stereo(), false)
                     .withOutput ("Output 4", AudioChannelSet::stereo(), false)
                     .withOutput ("Output 5", AudioChannelSet::stereo(), false)
                     .withOutput ("Output 6", AudioChannelSet::stereo(), false)
                     .withOutput ("Output 7", AudioChannelSet::stereo(), false)
                     .withOutput ("Output 8", AudioChannelSet::stereo(), false)
                     .withInput("Input", AudioChannelSet::stereo(), true))

and

bool TalCore::isBusesLayoutSupported (const BusesLayout& layouts) const
{
    return layouts.getMainInputChannels() == 2 &&
         (layouts.getMainOutputChannels() == 2
       || layouts.getMainOutputChannels() == 4
       || layouts.getMainOutputChannels() == 6
       || layouts.getMainOutputChannels() == 8
       || layouts.getMainOutputChannels() == 10
       || layouts.getMainOutputChannels() == 12
       || layouts.getMainOutputChannels() == 14
       || layouts.getMainOutputChannels() == 16);
}

It looks like this works in VST3 and AU hosts and I can add additional stereo outputs in the DAW.

But pro tools shows me this output option:

image

How can I remove the surround options and have the normal optional stereo outputs?

The layouts has two public arrays, I would check:

    for (const auto& bus : layout.outputBuses)
        if (bus != AudioChannelSet::stereo())
            return false; 

    if (layout.inputBuses.size() > 1)
        return false;

    if (layout.inputBuses.isNotEmpty() && layout.inputBuses [0] != AudioChannelSet::stereo())
        return false;

    return true;

Something along these lines

1 Like

Thanks, daniel. It worked. The surround configurations do not show up anymore :slight_smile: