Problem with input buffer with VST2

Hello,

I created a VST3 with JUCE, and it works fine. But not when I create the VST2 version of it.
The issue is in the processblock, the audiobuffer has 0 channels. I guess there is something obvious to do, but I was not able to figure out what it is.
In the projucer I have :

image

image

image

Does someone have a clue ?

Ok, I tried to create a new project and change each options, and it seems to be this one the issue :

image

I don’t really get why it would prevent to have channels, but disable it seems to fix the issue. Actually, all those options seems a bit confusing to me. A tooltip that explain what each of them really does could be really great