(Relative) Newbie problem (possibly with brain!)


#1

OK, this will probably be really simple for someone but:

Just updated to Juce 1.29 from 1.19 (bit of a gap I know), using VCExpress. Now whatever I try to build I get an error:

LINK : fatal error LNK1104: cannot open file ‘jucelib_static.lib’

Tried a few things but to no avail, so if anyone would like to point me in the right direction…


#2

You should link against “jucelib_debug_static.lib” and no more “jucelib_static.lib”

You’ll have to change this file in your project setting under the linker tab.
I think it is safe to remove the jucelib_static.lib from your project options anyway as it is included automatically if you build against Juce.

Sincerely,


#3

or it might just be that your library search path’s not got the juce/bin directory in it?


#4

Thanks for the advice, the library search path does have the juce/bin directory but there is no reference in there to to “jucelib_static.lib”, or any similars (such as the jucelib_debug_static.lib) is this normal?

When you say change to link against “jucelib_debug_static.lib”, I’m not quite sure how this is done. I assume it’s in the Project -> (Project Name) Properties -> Configuration Properties -> Linker tab, but beyone that I’m afraid you’ve lost me.


#5

erm - did you actually build the juce library…?


#6

You’d think I’d check that first wouldn’t you. I had a systems crash earlier, it must have been while I was building the library since only half of it was there. :?

I’ve rebuilt it now and the “jucelib_static_debug.lib” is there, but I’m still getting the error. I think I’m halfway there, still not sure about the linker stuff, maybe that’s the key?


#7

And now, as if by magic, it’s working. :smiley:

Cheers for the help guys, I’m putting you all in my will (I have nothing, but it’s the thought that counts, right?).


#8

hey well done :slight_smile: hope your project is going well


#9